Poor Performance on PC version

Is anyone else having this problem?

The matches are really jerky and no where near as fast or smooth as the PS2 version, I've tried on 640x480, 800x600 and higher, on low, med and high detail and all no good,

I'm running the game on an AMD 64 3500, 1GB DDR 400 Memory, Geforce 6800 Ultra. I didn't have this problem with PES4, but this did happen on the PES5 demo,

Anyone got any suggestions as this is making the game totally unplayable for me?
 

KOP_007

Banned
22 March 2003
Merseyside
PES4 was like this, crap on some peoples machines but good on others - despite specs being superior on the machine it ran crap on. Seemed hot and miss.

Did they ever find out what it was/is?

For reference:

I play PES at 1280x1024 with detail on high.

Specs: P4 3ghz, 512DDR, ATI Radeon 9800 128mb.

Perfect gameplay and beautiful graphics.
 

ericd

Non-League
19 August 2003
PIPEÑO said:
You have no hardware problem at all, lol.
Must be a driver problem. Try updating your drivers and get the latest DirectX.


for me its exactly the same prob , the pc version is always very slow and i dont know why
this is a shame that the ps2 version is much much faster than the pc version,it should be the contrary,and my drivers are the last one
i have a 3 ghz cpu intel and a 9800 ati radeon pro gt , 1 giga ram ,think its largelly enough for a pc version ,directx is 9.0c ,i think simply that the conversion is very badly done that s all like the pes4 on pc ,well i m going to play it on my ps2 instead of my pc....
 

Mattrats

Non-League
16 December 2004
Mattini Lambini said:
Is anyone else having this problem?

The matches are really jerky and no where near as fast or smooth as the PS2 version, I've tried on 640x480, 800x600 and higher, on low, med and high detail and all no good,

I'm running the game on an AMD 64 3500, 1GB DDR 400 Memory, Geforce 6800 Ultra. I didn't have this problem with PES4, but this did happen on the PES5 demo,

Anyone got any suggestions as this is making the game totally unplayable for me?
Here is a thread I left over on PESFAN .. hope it helps you all ;)

Ok guys, I guess there is a lot more people buying the game for PC for the first time this year .. so here is something that I found a while back for PES3 as I see some people having this problem again.

What this "Free" tool does is explained in full on the following link

http://www.majorgeeks.com/download.php?det=1847

I am not into all the technical jargon when it comes to PC's, but can say that it basically solves the problem of having to play the game in 60hz refresh rate.. all you have to do is download the tool and install and run and it will automatically adjust all your screen settings etc. and you will then be able to play in the refresh rate that your PC can handle. Before this, I had to play some games in 60 hz whilst having a good spec PC, well now I play all my games in 85hz :) including PES

Trust me that this thing works perfectly... for me anyway

Also, another tool to use, if you have ATI graphic card, is called Radlink.. rather than having to change the Vsync, AA or AF etc every time you play a different game on PC you can use this program and it is so simple to use.

I hope this helps some of you guys out and if you have any problems then let me know and I'll do my best to help..
 

cregser

La Liga
8 March 2004
Dublin
That refresh rate fix messed up something on my last PC. I couldn't maximise windows inside windows when I installed it (like a document inside Word, Acrobat reader, Excel etc.). I know they seem unrelated but when I uninstalled the "fix" I could maximise windows again. T'was a strange one.
 

jonboyo

Premiership
19 December 2002
ericd said:
for me its exactly the same prob , the pc version is always very slow and i dont know why
this is a shame that the ps2 version is much much faster than the pc version,it should be the contrary,and my drivers are the last one
i have a 3 ghz cpu intel and a 9800 ati radeon pro gt , 1 giga ram ,think its largelly enough for a pc version ,directx is 9.0c ,i think simply that the conversion is very badly done that s all like the pes4 on pc ,well i m going to play it on my ps2 instead of my pc....
Sounds like my PC specs, was the demo also running poorly on yours?
 

Domaldo

Non-League
12 August 2003
i fixed exactly the same problem by using nvidia control panel to set vsync on and 60hz refresh for pes5.exe

it now runs very smoothly:) same as ps2 version.
 
S

slupe

Guest
its to do with refresh rates probably m8.....change your monitor rate to 60hz
 

RuneEdge

Silent Assassin
1 October 2003
Manchester United
It has to be the refresh rate. I had this same problem for a looooooooooooooooooooooong time with PES4 and had no idea what it was cuz my specs are really high. But changing my monitor from 60hz(default) to 75hz did the trick for me.

The only problem I have with this is that if I'm using an application thats in fullscreen like Microsoft Media Centre, when I minimize it to view the desktop again, the screen flickers for a second. Not a major problem but it started happening have I changed to 75hz.
 

jonboyo

Premiership
19 December 2002
My demo version runs smooth but gameplay is definitally slower than ps2 version, thats after changing refresh,trying all resolutions and details high/med and low.Also used that RefreshForce 1.10 program listed above.

The players are slower which is not a problem since it plays like WE rather than pes, but shots now seem too slow...which is the only reason that I think mine may not be optimised.
Will stop me buying the PC version though.:(
 
Thanks to all that replied, its appreciated. The 60hz thing sorted it, now its smooth and its High Details 1280x1024 glory!

I'm guessing its because its a direct PS2 port, which could only do 60hz max, so the game just couldnt facilitate the 75hz my monitor was doing, its all cool though now, thanks everyone!
 
F

fr33

Guest
It's probably not your driver, nor your hardware.....For some reason Konami always has this compatibility problem with certain types of hardware (always been like that).

To give you an example: Got two systems, one AMD with Radeon card and another with P4 and Geforce 4. The P4 is my workstation, which for game is slower with less memory and more stuff running in the background (font server, tablet driver, stuff like that)
Both have a good clean install of XP, both have good tweaked drivers and I can play new games like FEAR at good framerates at high settings.

PES5 runs great on my P4, but runs like total crap on my AMD with a framerate between 24 and 41.

Believe me, this is totally due to the code of the game - nothing you can do about it.
 

mgc1971

League 1
30 November 2004
I have two computers with PES5 installed
One P4 2,8, 1gig Ram and an ATI 9800 pro.PES5 runs very smoothly at 1280x1024
Another one, a P4 3,4, 2 Gb DDR and an GeForce 6800 GT.Game plays really jerky, no matter how many changes I do - changing the refresh rate, adjusting medium settings, changing the resolution-
So I'm afraid there must be a problem with NVIDIA 6800 graphic cards.Hopefully, a patch will be released by Konami.........
 

shaffers17

Non-League
2 November 2005
can someone please post a screenshot of a match as I have a high end computer and pro evo is very choppy and the graphics arent that nice.
thanks
 
Mattini Lambini said:
Thanks to all that replied, its appreciated. The 60hz thing sorted it, now its smooth and its High Details 1280x1024 glory!

I'm guessing its because its a direct PS2 port, which could only do 60hz max, so the game just couldnt facilitate the 75hz my monitor was doing, its all cool though now, thanks everyone!


Erm I said it was fixed? Simple!
 

mazanga

League 1
12 October 2003
Groningen, Holland
You guys can also try this. I had the same problems with a amd3200+ and a 6800 card. I changed the refresh rate to 60 hz and forced vertical sync on in the nvidia control panel.

But sometimes changing the refresh rate to 60 hz does not work if you do it manually. It did not solve my problem anyway. Then i downloaded this program that u can use to really LOCK the 1280-1024 resolution (or any other resolution that you want to use for pes5) to 60hz.

After i did that, my problem was solved and the game runs soo smooth.

Give it a try. Check out the downloadlink:

http://www.majorgeeks.com/download.php?det=1847

for more information you can read this:

http://www.soccergaming.tv/showthread.php?t=127533&page=3&pp=15
 

chizzer

Conference
15 November 2004
A good tip for nvidia users is to get this
http://downloads.guru3d.com/download.php?det=815

It unlocks the potential to change refresh rates on your card at set resolutions. Smply download it, run the reg file then go into your card's control panel and override the refresh rate to 60hz on the resolution you play in.

For ATI card users, grab a program called radlink. You can set different profiles for each game.
 

mgc1971

League 1
30 November 2004
mazanga said:
You guys can also try this. I had the same problems with a amd3200+ and a 6800 card. I changed the refresh rate to 60 hz and forced vertical sync on in the nvidia control panel.

But sometimes changing the refresh rate to 60 hz does not work if you do it manually. It did not solve my problem anyway. Then i downloaded this program that u can use to really LOCK the 1280-1024 resolution (or any other resolution that you want to use for pes5) to 60hz.

After i did that, my problem was solved and the game runs soo smooth.

Give it a try. Check out the downloadlink:

http://www.majorgeeks.com/download.php?det=1847

for more information you can read this:

http://www.soccergaming.tv/showthread.php?t=127533&page=3&pp=15

Mazanga, you've saved my sorry ass
A thousand thanks.With that little program now PES5 runs smoothly
I owe you one m8
 

Diakor

Non-League
4 April 2003
Nvidia had the option to override refresh rates from the settings of the graphics card. Not anymore but if you follow my guide you will be able to have them again.

Go to START -> RUN and type regedit.
Go to HKEY_LOCAL_MACHINE -> SOFTWARE -> NVIDIA Corporation -> Global -> NVTweak.
At the right side of the window of the registry editor:
Right click-> New -> DWORD Value

Type: NvCplDisableRefreshRatePage
Double click the new value and enter the number 0.

Then at the nvidia settings page, you will have the override refresh rates option
 
Top Bottom